summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a5fc850..ca82084e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,15 +1,22 @@
cmake_minimum_required(VERSION 2.8.5)
+if(POLICY CMP0042)
+ # CMP0042 is only known to CMake 3.0 and above
+ cmake_policy(SET CMP0042 OLD)
+endif(POLICY CMP0042)
PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
-set(Ledger_VERSION_MINOR 0)
-set(Ledger_VERSION_PATCH 3)
-set(Ledger_VERSION_DATE 20140608)
+set(Ledger_VERSION_MINOR 1)
+set(Ledger_VERSION_PATCH 0)
+set(Ledger_VERSION_DATE 20141005)
enable_testing()
add_definitions(-std=c++11)
+if (CYGWIN)
+ add_definitions(-U__STRICT_ANSI__)
+endif()
########################################################################
@@ -45,6 +52,7 @@ endif()
########################################################################
+set(Python_ADDITIONAL_VERSIONS 2.7 2.6)
find_package(PythonInterp) # Used for running tests
if (USE_PYTHON)
@@ -52,7 +60,6 @@ if (USE_PYTHON)
message(ERROR "Building the python module requires BUILD_LIBRARY=ON.")
endif()
- set(Python_ADDITIONAL_VERSIONS 2.7 2.6)
find_package(PythonLibs)
if (PYTHONLIBS_FOUND)
set(BOOST_PYTHON python)
@@ -87,6 +94,7 @@ check_function_exists(access HAVE_ACCESS)
check_function_exists(realpath HAVE_REALPATH)
check_function_exists(getpwuid HAVE_GETPWUID)
check_function_exists(getpwnam HAVE_GETPWNAM)
+check_function_exists(ioctl HAVE_IOCTL)
check_function_exists(isatty HAVE_ISATTY)
check_c_source_compiles("