summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cc49fa8..ee88fe4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,10 @@ enable_testing()
add_definitions(-std=c++11)
+if (CYGWIN)
+ add_definitions(-U__STRICT_ANSI__)
+endif()
+
########################################################################
option(USE_PYTHON "Build support for the Python scripting bridge" OFF)