summaryrefslogtreecommitdiff
path: root/gdtoa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdtoa/Makefile.am')
-rw-r--r--gdtoa/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gdtoa/Makefile.am b/gdtoa/Makefile.am
new file mode 100644
index 00000000..4f4f11b7
--- /dev/null
+++ b/gdtoa/Makefile.am
@@ -0,0 +1,26 @@
+lib_LTLIBRARIES = libgdtoa.la
+
+libgdtoa_la_SOURCES = \
+ dmisc.c dtoa.c g_Qfmt.c g__fmt.c g_ddfmt.c g_dfmt.c g_ffmt.c \
+ g_xLfmt.c g_xfmt.c gdtoa.c gethex.c gmisc.c hd_init.c hexnan.c \
+ misc.c smisc.c strtoIQ.c strtoId.c strtoIdd.c strtoIf.c strtoIg.c \
+ strtoIx.c strtoIxL.c strtod.c strtodI.c strtodg.c strtof.c strtopQ.c \
+ strtopd.c strtopdd.c strtopf.c strtopx.c strtopxL.c strtorQ.c \
+ strtord.c strtordd.c strtorf.c strtorx.c strtorxL.c sum.c ulp.c
+
+$(libgdtoa_la_SOURCES): arith.h gd_qnan.h
+
+arith.h: arithchk.c
+ $(CC) $(CFLAGS) -o arithchk arithchk.c || \
+ $(CC) -DNO_LONG_LONG $(CFLAGS) -o arithchk arithchk.c
+ ./arithchk > arith.h
+
+gd_qnan.h: arith.h qnan.c
+ $(CC) $(CFLAGS) -o qnan qnan.c
+ ./qnan >gd_qnan.h
+
+libgdtoa_la_LDFLAGS = -release 1.0
+
+pkginclude_HEADERS = gdtoa.h
+
+CLEANFILES = arithchk qnan