summaryrefslogtreecommitdiff
path: root/lisp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lisp/CMakeLists.txt')
-rw-r--r--lisp/CMakeLists.txt19
1 files changed, 16 insertions, 3 deletions
diff --git a/lisp/CMakeLists.txt b/lisp/CMakeLists.txt
index 33fe6f14..9dee2abb 100644
--- a/lisp/CMakeLists.txt
+++ b/lisp/CMakeLists.txt
@@ -2,9 +2,12 @@ set(EMACS_LISP_SOURCES
ledger-commodities.el
ledger-complete.el
ledger-exec.el
+ ledger-fontify.el
ledger-fonts.el
+ ledger-fontify.el
ledger-init.el
ledger-mode.el
+ ledger-navigate.el
ledger-occur.el
ledger-post.el
ledger-reconcile.el
@@ -17,6 +20,9 @@ set(EMACS_LISP_SOURCES
ledger-texi.el
ledger-xact.el)
+set(EMACS_LISP_SOURCES_UNCOMPILABLE
+ ledger-context.el)
+
# find emacs and complain if not found
find_program(EMACS_EXECUTABLE emacs)
@@ -36,7 +42,14 @@ macro(add_emacs_lisp_target el)
COMMENT "Creating byte-compiled Emacs lisp ${CMAKE_CURRENT_BINARY_DIR}/${el}c")
endmacro(add_emacs_lisp_target el)
-if(EMACS_EXECUTABLE)
+if (EMACS_EXECUTABLE)
+ # uncompilable .el files
+ foreach(el ${EMACS_LISP_SOURCES_UNCOMPILABLE})
+ configure_file(${el} ${CMAKE_CURRENT_BINARY_DIR}/${el})
+ list(APPEND EMACS_LISP_UNCOMPILABLE ${CMAKE_CURRENT_BINARY_DIR}/${el})
+ endforeach()
+
+ # compilable .el files
foreach(el ${EMACS_LISP_SOURCES})
add_emacs_lisp_target(${el})
list(APPEND EMACS_LISP_BINARIES ${CMAKE_CURRENT_BINARY_DIR}/${el}c)
@@ -45,8 +58,8 @@ if(EMACS_EXECUTABLE)
add_custom_target(emacs_lisp_byte_compile ALL DEPENDS ${EMACS_LISP_BINARIES})
# install the byte-compiled emacs-lisp sources
- install(FILES ${EMACS_LISP_SOURCES} ${EMACS_LISP_BINARIES}
- DESTINATION share/emacs/site-lisp)
+ install(FILES ${EMACS_LISP_SOURCES} ${EMACS_LISP_BINARIES} ${EMACS_LISP_UNCOMPILABLE}
+ DESTINATION share/emacs/site-lisp/ledger-mode)
endif()
### CMakeLists.txt ends here