summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 9 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 0c78cb19..4413a88d 100755
--- a/setup.py
+++ b/setup.py
@@ -4,15 +4,16 @@ from distutils.core import setup, Extension
import os
-libs = ["amounts", "boost_python", "gmp"]
+defines = [('PYTHON_MODULE', 1)]
+libs = os.environ["PYLIBS"].split()
-setup(name = "Amounts",
- version = "2.6.1",
- description = "Amounts and Commodities Library",
+setup(name = "Ledger",
+ version = "2.7",
+ description = "Ledger Accounting Library",
author = "John Wiegley",
author_email = "johnw@newartisans.com",
- url = "http://www.newartisans.com/johnw/",
+ url = "http://www.newartisans.com/software/ledger.html",
ext_modules = [
- Extension("amounts", ["amounts.cc"],
- define_macros = [('PYTHON_MODULE', 1)],
- libraries = libs)])
+ Extension("ledger",
+ [os.path.join(os.environ['SRCDIR'], "pyledger.cc")],
+ define_macros = defines, libraries = libs)])