summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py20
1 files changed, 0 insertions, 20 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 96cf1f87..00000000
--- a/setup.py
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/usr/bin/env python
-
-from distutils.core import setup, Extension
-
-import os
-
-defines = [('PYTHON_MODULE', 1)]
-libs = os.environ["PYLIBS"].split()
-
-setup(name = "Ledger",
- version = "3.0",
- description = "Ledger Accounting Library",
- author = "John Wiegley",
- author_email = "johnw@newartisans.com",
- url = "http://johnwiegley.com/",
- ext_modules = [
- Extension("ledger",
- [os.path.join(os.environ['SRCDIR'],
- "src", "python", "pyledger.cc")],
- define_macros = defines, libraries = libs)])