summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py19
1 files changed, 0 insertions, 19 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index cb5db502..00000000
--- a/setup.py
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env python
-
-from distutils.core import setup, Extension
-
-import os
-
-defines = [('PYTHON_MODULE', 1)]
-libs = ["amounts", "boost_python", "gmp"]
-
-setup(name = "Amounts",
- version = "2.6.2",
- description = "Amounts and Commodities Library",
- author = "John Wiegley",
- author_email = "johnw@newartisans.com",
- url = "http://www.newartisans.com/johnw/",
- ext_modules = [
- Extension("amounts", [os.path.join(os.environ['SRCDIR'], "amounts.cc")],
- define_macros = [('PYTHON_MODULE', 1)],
- libraries = libs)])