summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 5ecd5a87..8d13d2d6 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -1,15 +1,15 @@
macro(add_ledger_test _name)
- add_ledger_library_dependencies(${_name})
+ target_link_libraries(${_name} libledger)
add_test(Ledger${_name} ${PROJECT_BINARY_DIR}/${_name})
endmacro(add_ledger_test _name)
include_directories(${PROJECT_SOURCE_DIR}/src)
-if(BUILD_LIBRARY)
+if (BUILD_LIBRARY)
add_executable(UtilTests t_times.cc)
add_ledger_test(UtilTests)
- add_executable(MathTests t_amount.cc t_commodity.cc t_balance.cc t_expr.cc)
+ add_executable(MathTests t_amount.cc t_commodity.cc t_balance.cc t_expr.cc t_value.cc)
add_ledger_test(MathTests)
set_target_properties(check PROPERTIES DEPENDS LedgerUtilTests)