From f6f4a46cf5b14f9a2170cd6475958efbf320caec Mon Sep 17 00:00:00 2001
From: John Wiegley <johnw@newartisans.com>
Date: Tue, 5 Aug 2008 13:17:04 -0400
Subject: Moved around most of the files so that source code is in src/,
 documentation is in doc/, etc.

---
 python/setup.py | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100755 python/setup.py

(limited to 'python/setup.py')

diff --git a/python/setup.py b/python/setup.py
new file mode 100755
index 00000000..4413a88d
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,19 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+import os
+
+defines = [('PYTHON_MODULE', 1)]
+libs    = os.environ["PYLIBS"].split()
+
+setup(name         = "Ledger",
+      version      = "2.7",
+      description  = "Ledger Accounting Library",
+      author       = "John Wiegley",
+      author_email = "johnw@newartisans.com",
+      url          = "http://www.newartisans.com/software/ledger.html",
+      ext_modules  = [
+	Extension("ledger",
+                  [os.path.join(os.environ['SRCDIR'], "pyledger.cc")],
+		  define_macros = defines, libraries = libs)])
-- 
cgit v1.2.3