summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cdd0bdc..a4057457 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -647,6 +647,10 @@ if (BUILD_TESTS)
set(WASM2C_CFLAGS "${WASM2C_CFLAGS} -g -O0")
endif ()
+ if (WABT_BIG_ENDIAN)
+ set(WASM2C_CFLAGS "${WASM2C_CFLAGS} -DWABT_BIG_ENDIAN=1")
+ endif ()
+
if (DEFINED CMAKE_OSX_SYSROOT)
set(WASM2C_CFLAGS "${WASM2C_CFLAGS} -isysroot ${CMAKE_OSX_SYSROOT}")
endif ()