summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 2 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db4081d..8be905e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,23 +2,8 @@ cmake_minimum_required(VERSION 3.0)
project(slgj C)
set(CMAKE_C_STANDARD 99)
-# the `pkg_check_modules` function is created with this call
-find_package(PkgConfig REQUIRED)
-
-# Adding Raylib
-include(FetchContent)
-set(FETCHCONTENT_QUIET FALSE)
-set(BUILD_EXAMPLES OFF CACHE BOOL "" FORCE) # don't build the supplied examples
-set(BUILD_GAMES OFF CACHE BOOL "" FORCE) # don't build the supplied example games
-
-FetchContent_Declare(
- raylib
- GIT_REPOSITORY "https://github.com/raysan5/raylib.git"
- GIT_TAG "master"
- GIT_PROGRESS TRUE
-)
-
-FetchContent_MakeAvailable(raylib)
+# Third party libs (currently only raylib)
+add_subdirectory(libs)
# Adding our source files
file(GLOB_RECURSE PROJECT_SOURCES CONFIGURE_DEPENDS "${CMAKE_CURRENT_LIST_DIR}/sources/*.c") # Define PROJECT_SOURCES as a list of all source files