summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91ef6c9..6504d85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ set(BUILD_GAMES OFF CACHE BOOL "" FORCE) # or games
add_subdirectory(libs/raylib)
-add_executable(${CMAKE_PROJECT_NAME} src/main.c)
-target_link_libraries(${CMAKE_PROJECT_NAME} PRIVATE raylib)
-target_compile_definitions(${CMAKE_PROJECT_NAME} PUBLIC ASSET_PATH="${CMAKE_CURRENT_SOURCE_DIR}/assets/")
+add_executable(raylib_template src/main.c)
+target_link_libraries(raylib_template PRIVATE raylib)
+target_compile_definitions(raylib_template PUBLIC ASSETS_PATH="${CMAKE_CURRENT_SOURCE_DIR}/assets/") # Set the asset path macro to the absolute path on the dev machine
+#target_compile_definitions(raylib_template PUBLIC ASSETS_PATH="relative-path-to-assets-in-the-game-package") # Set the asset path macro in release more