summaryrefslogtreecommitdiff
path: root/libs/raylib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/raylib/CMakeLists.txt')
-rw-r--r--libs/raylib/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/libs/raylib/CMakeLists.txt b/libs/raylib/CMakeLists.txt
deleted file mode 100644
index 5fe826d..0000000
--- a/libs/raylib/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-cmake_minimum_required(VERSION 3.0)
-project(raylib)
-
-# Directory for easier includes
-# Anywhere you see include(...) you can check <root>/cmake for that file
-set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
-
-# RAYLIB_IS_MAIN determines whether the project is being used from root
-# or if it is added as a dependency (through add_subdirectory for example).
-if ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
- set(RAYLIB_IS_MAIN TRUE)
-else()
- set(RAYLIB_IS_MAIN FALSE)
-endif()
-
-# Sets compiler flags and language standard
-include(CompilerFlags)
-
-# Registers build options that are exposed to cmake
-include(CMakeOptions.txt)
-
-# Enforces a few environment and compiler configurations
-include(BuildOptions)
-
-# Main sources directory (the second parameter sets the output directory name to raylib)
-add_subdirectory(src raylib)
-
-if (${BUILD_EXAMPLES})
- MESSAGE(STATUS "Building examples is enabled")
- add_subdirectory(examples)
-endif()
-
-enable_testing()