summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2013-05-29 01:19:56 -0500
committerJohn Wiegley <johnw@newartisans.com>2013-05-29 01:20:31 -0500
commit39841af0cec3b5d51ff18ee990a971572c8477a9 (patch)
treee979cbe8bb3602356c2aad81cd4b1969d1be5fed /CMakeLists.txt
parenta2518fa2a138e5836e00b080e817337b7584d5ac (diff)
downloadfork-ledger-39841af0cec3b5d51ff18ee990a971572c8477a9.tar.gz
fork-ledger-39841af0cec3b5d51ff18ee990a971572c8477a9.tar.bz2
fork-ledger-39841af0cec3b5d51ff18ee990a971572c8477a9.zip
Bump version number, fix README files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f8d8a87..fc2ef2bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
set(Ledger_VERSION_MINOR 0)
set(Ledger_VERSION_PATCH 0)
-set(Ledger_VERSION_DATE 20130523)
+set(Ledger_VERSION_DATE 20130529)
enable_testing()
@@ -292,6 +292,11 @@ set (CPACK_PACKAGE_VERSION_MAJOR "${Ledger_VERSION_MAJOR}")
set (CPACK_PACKAGE_VERSION_MINOR "${Ledger_VERSION_MINOR}")
set (CPACK_PACKAGE_VERSION_PATCH "${Ledger_VERSION_PATCH}")
+set (CPACK_SOURCE_GENERATOR "TBZ2")
+set (CPACK_SOURCE_PACKAGE_FILE_NAME
+ "${CMAKE_PROJECT_NAME}-${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
+set (CPACK_SOURCE_IGNORE_FILES "/.git*;/.dir-locals.el;~$;/doc/website/;/doc/wiki/;/lib/*.sh;/lib/Makefile;/tools/;${CPACK_SOURCE_IGNORE_FILES}")
+
include (CPack)
### CMakeLists.txt ends here