summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefano Zacchiroli <zack@upsilon.cc>2014-10-13 23:15:23 +0200
committerMartin Michlmayr <tbm@cyrius.com>2014-10-13 17:15:56 -0400
commit56976a127c081a6a008c81966360003a8711a319 (patch)
treeb27188861374e243746aaf561a0a9cf480989fbb /CMakeLists.txt
parent6b2520cc49edf4d167bec10850b832c308ebf9a3 (diff)
downloadfork-ledger-56976a127c081a6a008c81966360003a8711a319.tar.gz
fork-ledger-56976a127c081a6a008c81966360003a8711a319.tar.bz2
fork-ledger-56976a127c081a6a008c81966360003a8711a319.zip
make --columns default to terminal width, as returned by ioctl()
If set, the COLUMNS environment variable will take precedence over terminal width. However, please note that COLUMNS is usually *not* exported by shells to child processes, so in most cases COLUMNS will be undefined for ledger---hence the motivation for this change. Terminal width is queried using ioctl() on stdin. For the sake of portability the querying is done only on platform where ioctl() is detected as supported at compile-time.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6592f106..09d14051 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,7 @@ check_function_exists(access HAVE_ACCESS)
check_function_exists(realpath HAVE_REALPATH)
check_function_exists(getpwuid HAVE_GETPWUID)
check_function_exists(getpwnam HAVE_GETPWNAM)
+check_function_exists(ioctl HAVE_IOCTL)
check_function_exists(isatty HAVE_ISATTY)
check_c_source_compiles("