summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Erik van Elburg <hanserik@vanelburg.net>2015-01-03 02:27:27 +0100
committerHans Erik van Elburg <hanserik@vanelburg.net>2015-01-03 02:27:27 +0100
commit617be983b9d9afd67dd1752f3331f02a4450361e (patch)
treeb1e920b2f5a4b6888c8134bed8b29ff3d89cc8d0 /CMakeLists.txt
parent2c277112b6179b3df1679f25d03f001b8ac1c26d (diff)
downloadfork-ledger-617be983b9d9afd67dd1752f3331f02a4450361e.tar.gz
fork-ledger-617be983b9d9afd67dd1752f3331f02a4450361e.tar.bz2
fork-ledger-617be983b9d9afd67dd1752f3331f02a4450361e.zip
initial cygwin tweaks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cc49fa8..04d35a88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,11 @@ set(Ledger_VERSION_DATE 20141005)
enable_testing()
-add_definitions(-std=c++11)
+if (CYGWIN)
+ add_definitions(-std=c++11 -U__STRICT_ANSI__)
+else()
+ add_definitions(-std=c++11)
+endif()
########################################################################