summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Earls <enderw88@gmail.com>2015-06-28 19:35:31 -0700
committerCraig Earls <enderw88@gmail.com>2015-06-28 19:35:31 -0700
commit6e92d87d907cb3663f9c463da215f21c7e30bc39 (patch)
tree138ae6d97c0a53d6f8174aae985c4b0fd92a83d5 /CMakeLists.txt
parent5f03a94b522f4c348ae952e2dfdba98e71a35b8f (diff)
parent45e74103607a77c5945615692c3a35f9ce6aadde (diff)
downloadfork-ledger-6e92d87d907cb3663f9c463da215f21c7e30bc39.tar.gz
fork-ledger-6e92d87d907cb3663f9c463da215f21c7e30bc39.tar.bz2
fork-ledger-6e92d87d907cb3663f9c463da215f21c7e30bc39.zip
Merge commit '45e74103607a77c5945615692c3a35f9ce6aadde' into next
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da075cde..6166780c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,7 +225,14 @@ macro(add_ledger_library_dependencies _target)
target_link_libraries(${_target} ${INTL_LIB})
endif()
if (HAVE_BOOST_PYTHON)
- target_link_libraries(${_target} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
+ if(APPLE)
+ # Don't link directly to a Python framework on OS X, to avoid segfaults
+ # when the module is imported from a different interpreter
+ target_link_libraries(${_target} ${Boost_LIBRARIES})
+ set_target_properties(${_target} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+ else()
+ target_link_libraries(${_target} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
+ endif()
else()
target_link_libraries(${_target} ${Boost_LIBRARIES})
endif()