summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2012-05-20 05:30:55 -0500
committerJohn Wiegley <johnw@newartisans.com>2012-05-20 05:30:55 -0500
commit8faae6663862f186f5628c23f645384e7d30587a (patch)
tree93320285084c780f7350fa525f05b1762b7aa4d5 /CMakeLists.txt
parent9c9534d562afc21f79d1c969919489a5394e108d (diff)
downloadfork-ledger-8faae6663862f186f5628c23f645384e7d30587a.tar.gz
fork-ledger-8faae6663862f186f5628c23f645384e7d30587a.tar.bz2
fork-ledger-8faae6663862f186f5628c23f645384e7d30587a.zip
Define some more missing CMake variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 277de435..f60dcf7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,11 +24,15 @@ option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)
set(CMAKE_BUILD_TYPE Debug)
set(DEBUG_MODE 1)
+ set(NDEBUG 0)
elseif(NO_ASSERTS)
set(CMAKE_BUILD_TYPE Release)
+ set(DEBUG_MODE 0)
set(NDEBUG 1)
else()
set(CMAKE_BUILD_TYPE Release)
+ set(DEBUG_MODE 0)
+ set(NDEBUG 0)
endif()
########################################################################