summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2015-08-04 14:14:20 -0700
committerJohn Wiegley <johnw@newartisans.com>2015-08-04 14:14:20 -0700
commit947a46ebebd141e928a9fcebb584e34df4e210a7 (patch)
tree4cb81e0e1c08d182ac86df3a6caa4dcc8ea90c53 /CMakeLists.txt
parent614ba7d2136ab2b84abf74d7922a4f5d19b756cb (diff)
parent967a76193eb241ea99ae7d99d1f813590fa12ae3 (diff)
downloadfork-ledger-947a46ebebd141e928a9fcebb584e34df4e210a7.tar.gz
fork-ledger-947a46ebebd141e928a9fcebb584e34df4e210a7.tar.bz2
fork-ledger-947a46ebebd141e928a9fcebb584e34df4e210a7.zip
Merge pull request #369 from afh/pull/utfcpp_subtree
Replace utfcpp submodule with partial subtree
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c8c36ef..e455ec02 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,9 @@ set(Ledger_VERSION_PATCH 1)
set(Ledger_VERSION_PRERELEASE "-alpha.1")
set(Ledger_VERSION_DATE 20141005)
+# Point CMake at any custom modules we may ship
+list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
+
enable_testing()
add_definitions(-std=c++11)
@@ -244,13 +247,20 @@ endmacro(add_ledger_library_dependencies _target)
########################################################################
+include(FindUtfcpp)
+if (UTFCPP_FOUND)
+ include_directories("${UTFCPP_INCLUDE_DIR}")
+else()
+ message(FATAL_ERROR "Missing required header file: utf8.h\n"
+ "Define UTFCPP_PATH or install utfcpp locally into the source tree below lib/utfcpp/."
+ )
+endif()
+
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
# add the binary tree to the search path for include files so that we will
-# find TutorialConfig.h
-include_directories("${PROJECT_SOURCE_DIR}/lib")
-include_directories("${PROJECT_SOURCE_DIR}/lib/utfcpp/source")
+# find system.hh
include_directories("${PROJECT_BINARY_DIR}")
configure_file(