summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2014-12-22 20:06:18 +0100
committerAlexis Hildebrandt <afh@surryhill.net>2014-12-24 09:30:17 +0100
commitac5fd3afd3826a9b0fadcb270900cf42c5ee6e39 (patch)
tree67e96c0016815ffd5094e5313f20f56aebc4702a /CMakeLists.txt
parent5b42031ec1812b9f1b0d8641f44c2b1a76bf6265 (diff)
downloadfork-ledger-ac5fd3afd3826a9b0fadcb270900cf42c5ee6e39.tar.gz
fork-ledger-ac5fd3afd3826a9b0fadcb270900cf42c5ee6e39.tar.bz2
fork-ledger-ac5fd3afd3826a9b0fadcb270900cf42c5ee6e39.zip
Set CMake policy CMP0042
to remove the warning below when running cmake. In the long run changing the CMake rules to set MACOSX_RPATH might be the better option. CMake Warning (dev): Policy CMP0042 is not set: MACOSX_RPATH is enabled by default. Run "cmake --help-policy CMP0042" for policy details. Use the cmake_policy command to set the policy and suppress this warning. MACOSX_RPATH is not specified for the following targets: libledger This warning is for project developers. Use -Wno-dev to suppress it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09d14051..5cc49fa8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,8 @@
cmake_minimum_required(VERSION 2.8.5)
+if(POLICY CMP0042)
+ # CMP0042 is only known to CMake 3.0 and above
+ cmake_policy(SET CMP0042 OLD)
+endif(POLICY CMP0042)
PROJECT(ledger)