summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohann Klähn <kljohann@gmail.com>2013-01-14 16:23:16 +0100
committerJohann Klähn <kljohann@gmail.com>2013-01-14 21:35:26 +0100
commitc88862fd66489fa8c06d06d3876b2c0f59dff3a5 (patch)
treec6724d47fa3e3d273e6bc1c98647228b84d8c33d /CMakeLists.txt
parentedc272b7a065a41574492a75310b726174e86ec6 (diff)
downloadfork-ledger-c88862fd66489fa8c06d06d3876b2c0f59dff3a5.tar.gz
fork-ledger-c88862fd66489fa8c06d06d3876b2c0f59dff3a5.tar.bz2
fork-ledger-c88862fd66489fa8c06d06d3876b2c0f59dff3a5.zip
convert doc/Makefile to CMake
CMake will build the pdf version of the manual if texi2pdf is installed. It will be installed to DOCDIR/ledger{,3}.pdf, for example /usr/local/share/ledger/ledger3.pdf. Also, the man page will be installed to MANDIR/man1/ledger.1 The option BUILD_DOCS is now on by default. A new option BUILD_WEB_DOCS is used to toggle the generation of the html version of the manual and the man page (off by default). All this is added to the 'doc' make target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4109a17..132d7c47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.5)
-project(Ledger)
+PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
set(Ledger_VERSION_MINOR 0)
@@ -18,7 +18,8 @@ option(DISABLE_ASSERTS "Build without any internal consistency checks" OFF)
option(BUILD_DEBUG "Build support for runtime debugging" OFF)
option(BUILD_LIBRARY "Build and install Ledger as a library" ON)
-option(BUILD_DOCS "Build and install documentation" OFF)
+option(BUILD_DOCS "Build and install documentation" ON)
+option(BUILD_WEB_DOCS "Build version of documentation suitable for viewing online" OFF)
option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)