summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2015-01-04 00:23:37 -0600
committerJohn Wiegley <johnw@newartisans.com>2015-01-04 00:23:37 -0600
commitd6f194058fbf8c88b926c2cb7ed43aa4ff255bc0 (patch)
tree27466ec14cf9bc9ee73312b2396f15394cca8b79 /CMakeLists.txt
parenta31ff149163c082eb06b7ee9cf925828241f858c (diff)
parent0a43c7df4284f5c096be4355539c016396d8661c (diff)
downloadfork-ledger-d6f194058fbf8c88b926c2cb7ed43aa4ff255bc0.tar.gz
fork-ledger-d6f194058fbf8c88b926c2cb7ed43aa4ff255bc0.tar.bz2
fork-ledger-d6f194058fbf8c88b926c2cb7ed43aa4ff255bc0.zip
Merge pull request #360 from jmgpena/BUG-985-Fix-Cygwin-Compilation-Issue
Fix for BUG 985
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cc49fa8..ee88fe4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,10 @@ enable_testing()
add_definitions(-std=c++11)
+if (CYGWIN)
+ add_definitions(-U__STRICT_ANSI__)
+endif()
+
########################################################################
option(USE_PYTHON "Build support for the Python scripting bridge" OFF)