summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2012-05-20 16:07:43 -0500
committerJohn Wiegley <johnw@newartisans.com>2012-05-20 16:07:43 -0500
commitde7322b48c09cceef0df3710f8c0d35021e23967 (patch)
tree2c21f2f7722e6636a00b9fd7604c1832b5b9a79e /CMakeLists.txt
parent05d1704eb81490c7e80d2b650d04f77d07624c73 (diff)
downloadfork-ledger-de7322b48c09cceef0df3710f8c0d35021e23967.tar.gz
fork-ledger-de7322b48c09cceef0df3710f8c0d35021e23967.tar.bz2
fork-ledger-de7322b48c09cceef0df3710f8c0d35021e23967.zip
Handle NO_ASSERTS differently in CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b91eaa29..9eb39e3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ enable_testing()
option(USE_PYTHON "Build support for the Python scripting bridge" OFF)
option(USE_DOXYGEN "Build reference documentation using Doxygen" OFF)
-option(NO_ASSERTS "Build without any internal consistency checks" OFF)
+option(DISABLE_ASSERTS "Build without any internal consistency checks" OFF)
option(BUILD_DEBUG "Build support for runtime debugging" OFF)
option(BUILD_LIBRARY "Build and install Ledger as a library" ON)
@@ -29,6 +29,12 @@ else()
set(DEBUG_MODE 0)
endif()
+if(DISABLE_ASSERTS)
+ set(NO_ASSERTS 1)
+else()
+ set(NO_ASSERTS 0)
+endif()
+
if(CLANG_GCOV)
set(PROFILE_LIBS profile_rt)
set(CMAKE_REQUIRED_LIBRARIES ${PROFILE_LIBS})