summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohann Klähn <kljohann@gmail.com>2015-01-06 10:03:03 +0100
committerJohann Klähn <kljohann@gmail.com>2015-01-06 10:03:03 +0100
commitf2b61846d10388ec658c58f47b24b14e5b9489fc (patch)
treeaba973b91f6b6010d99bb47cd3976797ee4ef570 /CMakeLists.txt
parentca8eded48e54e81dce5b5bb11749c2439d72162e (diff)
downloadfork-ledger-f2b61846d10388ec658c58f47b24b14e5b9489fc.tar.gz
fork-ledger-f2b61846d10388ec658c58f47b24b14e5b9489fc.tar.bz2
fork-ledger-f2b61846d10388ec658c58f47b24b14e5b9489fc.zip
use the same python version for lib and interpreter
Currently the path to install the python library in is determined by running the python interpreter. We do not want to end up installing a library built for python2 in the python3 library path!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70b5fe1a..ca82084e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,7 @@ endif()
########################################################################
+set(Python_ADDITIONAL_VERSIONS 2.7 2.6)
find_package(PythonInterp) # Used for running tests
if (USE_PYTHON)
@@ -59,7 +60,6 @@ if (USE_PYTHON)
message(ERROR "Building the python module requires BUILD_LIBRARY=ON.")
endif()
- set(Python_ADDITIONAL_VERSIONS 2.7 2.6)
find_package(PythonLibs)
if (PYTHONLIBS_FOUND)
set(BOOST_PYTHON python)