summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Earls <enderw88@gmail.com>2014-04-19 21:56:14 -0700
committerCraig Earls <enderw88@gmail.com>2014-04-19 21:56:14 -0700
commitfd18f58392833d6e1b1c06a7700f8afc37711c87 (patch)
tree895daa013b63caeed47bd944daba89003e9b34ce /CMakeLists.txt
parent7faaeb301fe524422c694e54fa36248ffedfa9b8 (diff)
parenta0c5addbbdaf472d26ae25c86ff826e509b3ee17 (diff)
downloadfork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.tar.gz
fork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.tar.bz2
fork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.zip
Merge commit 'a0c5addbbdaf472d26ae25c86ff826e509b3ee17'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 5 insertions, 34 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c60cdce2..b7289748 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,11 +4,13 @@ PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
set(Ledger_VERSION_MINOR 0)
-set(Ledger_VERSION_PATCH 1)
-set(Ledger_VERSION_DATE 20140327)
+set(Ledger_VERSION_PATCH 2)
+set(Ledger_VERSION_DATE 20140417)
enable_testing()
+add_definitions(-std=c++11)
+
########################################################################
option(USE_PYTHON "Build support for the Python scripting bridge" OFF)
@@ -65,7 +67,7 @@ else()
endif()
# Set BOOST_ROOT to help CMake to find the right Boost version
-find_package(Boost 1.46.0
+find_package(Boost 1.55.0
REQUIRED date_time filesystem system iostreams regex unit_test_framework
${BOOST_PYTHON})
@@ -148,37 +150,6 @@ endif()
cmake_pop_check_state()
-#cmake_push_check_state()
-#
-#set(CMAKE_REQUIRED_FLAGS -std=c++11)
-#set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INCLUDE_PATH})
-#
-#check_cxx_source_runs("
-##include <regex>
-##include <vector>
-##include <iostream>
-#
-#int main() {
-# std::vector<int> x {0, 1, 2, 3, 4};
-# for (auto i : x)
-# std::cout << i << std::endl;
-#
-# std::regex r(\"foo\");
-# std::cout << std::regex_match(\"foobar\", r) << std::endl;
-# return 0;
-#}" CXX11_RUNS)
-#
-#cmake_pop_check_state()
-#
-#if(CXX11_RUNS)
-# set(HAVE_CXX11 1)
-# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
-#else()
- set(HAVE_CXX11 0)
-#endif()
-#
-#cmake_pop_check_state()
-
########################################################################
include_directories(${CMAKE_INCLUDE_PATH})