summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2009-01-26 20:50:17 -0400
committerJohn Wiegley <johnw@newartisans.com>2009-01-26 20:50:17 -0400
commit21707033108fccbd24e03c98677131b7dd74a5f7 (patch)
treea0bb95af39bb3c86eb0c97b4e4d14e5796817074 /Makefile.am
parent7d597da99bd49c2c08e0493ab7f79308bad0cd80 (diff)
downloadfork-ledger-21707033108fccbd24e03c98677131b7dd74a5f7.tar.gz
fork-ledger-21707033108fccbd24e03c98677131b7dd74a5f7.tar.bz2
fork-ledger-21707033108fccbd24e03c98677131b7dd74a5f7.zip
Fixed TAGS target to work when building in a separate output dir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 182652e9..c36701a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -233,7 +233,8 @@ all_sources = $(libledger_util_la_SOURCES) \
all_files = $(all_sources) $(pkginclude_HEADERS)
TAGS: $(all_sources)
- @etags $(all_sources)
+ BUILD_DIR=`cd $(top_builddir); pwd`; \
+ (cd $(srcdir); etags -o $$BUILD_DIR/TAGS $(all_sources))
@echo TAGS rebuilt.
######################################################################