summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2009-03-10 02:07:05 -0400
committerJohn Wiegley <johnw@newartisans.com>2009-03-10 02:07:05 -0400
commit36b38c11942a4eb0fab1ebac121ef0012b5a08bf (patch)
treea79a2a9ead247b9b16eab255859f3aa5bd70ee5f /Makefile.am
parent6fe6882ee493dedf2eab401f3b9f738d037ce139 (diff)
downloadfork-ledger-36b38c11942a4eb0fab1ebac121ef0012b5a08bf.tar.gz
fork-ledger-36b38c11942a4eb0fab1ebac121ef0012b5a08bf.tar.bz2
fork-ledger-36b38c11942a4eb0fab1ebac121ef0012b5a08bf.zip
Fixed the 'acprep distcheck' build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index baa21da9..27bca7d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,8 +81,6 @@ libledger_report_la_CPPFLAGS = $(lib_cppflags)
libledger_report_la_LDFLAGS = -release $(VERSION).0
pkginclude_HEADERS = \
- $(top_builddir)/config.h \
- $(top_builddir)/system.hh \
src/utils.h \
src/flags.h \
src/hooks.h \
@@ -145,24 +143,24 @@ pkginclude_HEADERS = \
lib/utfcpp/source/utf8/core.h \
lib/utfcpp/source/utf8/unchecked.h
-nodist_libledger_util_la_SOURCES = $(top_builddir)/system.hh
+nodist_libledger_util_la_SOURCES = system.hh
-BUILT_SOURCES = $(top_builddir)/system.hh
-CLEANFILES = system.hh
+BUILT_SOURCES = system.hh
+CLEANFILES = system.hh
system.hh: src/system.hh.in
cp -p $< $@
if USE_PCH
-nodist_libledger_util_la_SOURCES += $(top_builddir)/system.hh.gch
+nodist_libledger_util_la_SOURCES += system.hh.gch
-BUILT_SOURCES += $(top_builddir)/system.hh.gch
-CLEANFILES += system.hh.gch
+BUILT_SOURCES += system.hh.gch
+CLEANFILES += system.hh.gch
-system.hh.gch: $(top_builddir)/system.hh
+system.hh.gch: system.hh
$(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
$(lib_cppflags) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) \
- -o $@ $(top_builddir)/system.hh
+ -o $@ $<
endif
######################################################################