summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-11 07:20:49 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:42 -0400
commit48b46a23b183fc576f7e999a166d1e130233032c (patch)
tree5d3b645149d473a2638431450e73efcc0905e921 /Makefile.am
parent8e20c378d6ee6eb36f8c6866f8c9ec52f8600c58 (diff)
downloadfork-ledger-48b46a23b183fc576f7e999a166d1e130233032c.tar.gz
fork-ledger-48b46a23b183fc576f7e999a166d1e130233032c.tar.bz2
fork-ledger-48b46a23b183fc576f7e999a166d1e130233032c.zip
Disabled compiler warnings from icc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ec279b4..19d6435c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,8 @@ WARNFLAGS = -Wall -Wextra -Wfloat-equal -Wno-endif-labels
WARNFLAGS += -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion
WARNFLAGS += -Wconversion -Wshorten-64-to-32 -Wsign-compare
WARNFLAGS += -Wmissing-field-initializers -pedantic-errors
+WARNFLAGS += -Weffc++ -Wstrict-null-sentinel -Wold-style-cast
+WARNFLAGS += -Woverloaded-virtual -Wsign-promo
libledger_la_CPPFLAGS = -I$(top_builddir)/gdtoa -I$(srcdir)/gdtoa \
-I$(srcdir)/src #$(WARNFLAGS)