summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2008-08-09 19:48:23 -0400
committerJohn Wiegley <johnw@newartisans.com>2008-08-09 19:48:23 -0400
commit6fe833bb9b8486404b34fb8b5e2f730cdfb50a06 (patch)
tree569eb87ca21a74b756cda1739bce3a45a62722b6 /Makefile.am
parent5419e74378134d34894c8f25d54e8a28482ff5a8 (diff)
downloadfork-ledger-6fe833bb9b8486404b34fb8b5e2f730cdfb50a06.tar.gz
fork-ledger-6fe833bb9b8486404b34fb8b5e2f730cdfb50a06.tar.bz2
fork-ledger-6fe833bb9b8486404b34fb8b5e2f730cdfb50a06.zip
Moved sources which I did not write from src/ into lib/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e8f18a25..2e79bddb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ EXTRA_DIST = contrib
lib_LTLIBRARIES = libamounts.la libledger.la
-libamounts_la_CPPFLAGS = -I$(srcdir)/src
+libamounts_la_CPPFLAGS = -I$(srcdir)/src -I$(srcdir)/lib
libamounts_la_SOURCES = \
src/utils.cc \
src/times.cc \
@@ -77,7 +77,6 @@ endif
pkginclude_HEADERS = \
acconf.h \
src/system.hh \
- src/fdstream.h \
src/utils.h \
src/flags.h \
src/hooks.h \
@@ -87,6 +86,8 @@ pkginclude_HEADERS = \
src/mask.h \
src/binary.h \
\
+ lib/fdstream.h \
+ \
src/amount.h \
src/commodity.h \
src/balance.h \
@@ -178,8 +179,9 @@ libpyledger_la_SOURCES = \
python/pyfstream.h \
python/pyinterp.cc \
python/pyutils.h \
- python/tuples.h \
- python/setup.py
+ python/setup.py \
+ \
+ lib/tuples.h
libpyledger_la_CPPFLAGS = $(libledger_la_CPPFLAGS) -I$(srcdir)/python