summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2009-02-24 13:16:28 -0400
committerJohn Wiegley <johnw@newartisans.com>2009-02-24 13:16:28 -0400
commitd525db35d879d367264ce3093d508f6b3d9b5f89 (patch)
tree8da522d2d10bd77784a76ff3ee2f49e0b8f2c181 /Makefile.am
parent07fcc3a08af552bd40d4bd5103d4668662acdaf4 (diff)
downloadfork-ledger-d525db35d879d367264ce3093d508f6b3d9b5f89.tar.gz
fork-ledger-d525db35d879d367264ce3093d508f6b3d9b5f89.tar.bz2
fork-ledger-d525db35d879d367264ce3093d508f6b3d9b5f89.zip
Restored the use of Python unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c60202d..a6254fdd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -247,9 +247,9 @@ TESTS += \
report_tests
endif
-#if HAVE_BOOST_PYTHON
-#TESTS += PyUnitTests
-#endif
+if HAVE_BOOST_PYTHON
+TESTS += PyUnitTests
+endif
check_PROGRAMS = $(TESTS)
@@ -312,7 +312,7 @@ all_tests_sources = \
$(data_tests_SOURCES) \
$(report_tests_SOURCES)
-#PyUnitTests_SOURCES = test/__init__.py test/PyUnitTests.py
+PyUnitTests_SOURCES = test/__init__.py test/PyUnitTests.py
all_py_tests_sources = \
$(patsubst test/unit/%.cc,$(top_builddir)/test/python/%.py, \
@@ -345,12 +345,12 @@ ESC_distdir=`echo "$(distdir)" | sed 's/\//\\\\\//g'`
# jww (2007-05-10): This rule will not be triggered on systems that
# define an EXEEXT.
-#PyUnitTests: $(srcdir)/test/PyUnitTests.py test/python/UnitTests.py
-# @cat $(srcdir)/test/PyUnitTests.py \
-# | sed "s/%python%/$(ESC_python)/" \
-# | sed "s/%srcdir%/$(ESC_srcdir)/g" \
-# | sed "s/%builddir%/$(ESC_builddir)/g" > $@
-# chmod 755 $@
+PyUnitTests: $(srcdir)/test/PyUnitTests.py test/python/UnitTests.py
+ @cat $(srcdir)/test/PyUnitTests.py \
+ | sed "s/%python%/$(ESC_python)/" \
+ | sed "s/%srcdir%/$(ESC_srcdir)/g" \
+ | sed "s/%builddir%/$(ESC_builddir)/g" > $@
+ chmod 755 $@
RegressionTests_SOURCES = test/regress.py