summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-04-14 04:25:32 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:35:31 -0400
commite65c62d5a42b812dfdcc8841e813ff96ee26c8ba (patch)
treee97ad9e183a9c941c4c796f1171c25bcad832033 /Makefile.am
parent6dbb6ec18638f399e2473ff1cb7e6db5f1b0accf (diff)
downloadfork-ledger-e65c62d5a42b812dfdcc8841e813ff96ee26c8ba.tar.gz
fork-ledger-e65c62d5a42b812dfdcc8841e813ff96ee26c8ba.tar.bz2
fork-ledger-e65c62d5a42b812dfdcc8841e813ff96ee26c8ba.zip
Removed all uses of PCH (which was far more trouble than it was worth).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ec5dab0..346008ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,47 +1,6 @@
-if USE_PCH
-#BUILT_SOURCES = pchpic.h.gch pchnopic.h.gch
-BUILT_SOURCES = pchnopic.h.gch
-#CLEANFILES = pchpic.h.gch pchnopic.h.gch
-CLEANFILES = pchnopic.h.gch
-endif
-
-######################################################################
-
-#bin_PROGRAMS = xpath
-#
-#xpath_CXXFLAGS = -DTEST
-#xpath_SOURCES = \
-# amount.cc \
-# datetime.cc \
-# quotes.cc \
-# balance.cc \
-# value.cc \
-# mask.cc \
-# xml.cc \
-# xpath.cc \
-# trace.cc \
-# util.cc
-#xpath_LDADD = $(LIBOBJS)
-#if HAVE_EXPAT
-#xpath_CXXFLAGS += -DHAVE_EXPAT=1
-#endif
-#if HAVE_XMLPARSE
-#xpath_CXXFLAGS += -DHAVE_XMLPARSE=1
-#endif
-#if DEBUG
-#xpath_CXXFLAGS += -DDEBUG_LEVEL=4
-#xpath_SOURCES += debug.cc
-#endif
-#xpath_LDFLAGS = -static # for the sake of command-line speed
-
-######################################################################
-
lib_LTLIBRARIES = libledger.la
libledger_la_CXXFLAGS =
-if USE_PCH
-libledger_la_CXXFLAGS += -DUSE_PCH -Winvalid-pch -fpch-deps
-endif
libledger_la_SOURCES = \
amount.cc \
quotes.cc \
@@ -129,12 +88,6 @@ pkginclude_HEADERS = \
xml.h \
xpath.h
-pchpic.h.gch: pch.h pchdata.h $(pkginclude_HEADERS)
- $(CXXCOMPILE) $(CXXFLAGS) -DPIC -o $@ pchdata.h
-
-pchnopic.h.gch: pch.h pchdata.h $(pkginclude_HEADERS)
- $(CXXCOMPILE) $(CXXFLAGS) -o $@ pchdata.h
-
######################################################################
bin_PROGRAMS = ledger