summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-11 07:23:22 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:44 -0400
commitf397ef9cbc021e73db66cd93cff6ebd622678a0f (patch)
tree025cd4b3cb3558c2bdc7fe2cdfdaed6c11b99323 /Makefile.am
parenta1c225eeb6206195ddafebba9b5b4db1caf90f65 (diff)
downloadfork-ledger-f397ef9cbc021e73db66cd93cff6ebd622678a0f.tar.gz
fork-ledger-f397ef9cbc021e73db66cd93cff6ebd622678a0f.tar.bz2
fork-ledger-f397ef9cbc021e73db66cd93cff6ebd622678a0f.zip
Upgraded automake file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 99e86a74..58457657 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@ ESC_srcdir=`echo "$(srcdir)" | sed 's/\//\\\\\//g'`
ESC_builddir=`echo "$(top_builddir)" | sed 's/\//\\\\\//g'`
ESC_distdir=`echo "$(distdir)" | sed 's/\//\\\\\//g'`
-EXTRA_DIST = docs tests
+EXTRA_DIST = docs docs/ledger.pdf tests
#(cd $(distdir)/docs; zip -r doxygen-html.zip html; rm -fr html)
dist-hook:
@@ -237,18 +237,18 @@ UnitTests_LDADD = $(lib_LTLIBRARIES) gdtoa/libgdtoa.la -lcppunit
PyUnitTests_SOURCES = tests/python/PyUnitTests.py
-PyUnitTests: $(srcdir)/tests/python/PyUnitTests.py
+PyUnitTests): $(srcdir)/tests/python/PyUnitTests.py
cat $(srcdir)/tests/python/PyUnitTests.py \
| sed "s/%srcdir%/$(ESC_srcdir)/g" \
| sed "s/%builddir%/$(ESC_builddir)/g" > $@
chmod 755 $@
fullcheck: check
- MallocGuardEdges=1 \
- MallocScribble=1 \
- MallocPreScribble=1 \
+ MallocGuardEdges=1 \
+ MallocScribble=1 \
+ MallocPreScribble=1 \
MallocCheckHeapStart=100 \
- MallocCheckHeapEach=100 \
+ MallocCheckHeapEach=100 \
DYLD_INSERT_LIBRARIES=/usr/lib/libgmalloc.dylib \
$(srcdir)/valgrind.sh $(top_builddir)/UnitTests --verify