summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 02:53:28 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:40 -0400
commitfa81dc479801ba1343695d66cdb37d8b80bfae9d (patch)
tree835724102a2c99a88d9e67bae71a94ee49e1f674 /Makefile.am
parentee4a16743960122bf2b626f62827b7332680ebf5 (diff)
downloadfork-ledger-fa81dc479801ba1343695d66cdb37d8b80bfae9d.tar.gz
fork-ledger-fa81dc479801ba1343695d66cdb37d8b80bfae9d.tar.bz2
fork-ledger-fa81dc479801ba1343695d66cdb37d8b80bfae9d.zip
Added target fullcheck.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 59d2add1..81e6da18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -234,6 +234,13 @@ PyUnitTests: $(srcdir)/tests/python/PyUnitTests.py
| sed "s/%builddir%/$(ESC_builddir)/g" > $@
chmod 755 $@
+fullcheck: UnitTests
+ MallocGuardEdges=1 \
+ MallocScribble=1 \
+ MallocPreScribble=1 \
+ DYLD_INSERT_LIBRARIES=/usr/lib/libgmalloc.dylib \
+ $(top_builddir)/UnitTests --verify
+
######################################################################
DISTCLEANFILES = Doxyfile.gen