summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2009-01-23 15:59:01 -0400
committerJohn Wiegley <johnw@newartisans.com>2009-01-23 15:59:01 -0400
commitfc8dd144673675d959a3a8c7c2049f6bf12dd814 (patch)
treef07b2b76e68e89cf3e526b9ad1200b3802bf395c /Makefile.am
parent7aa42aa8b3947a43e128d1fe9123aef9c9c1b844 (diff)
downloadfork-ledger-fc8dd144673675d959a3a8c7c2049f6bf12dd814.tar.gz
fork-ledger-fc8dd144673675d959a3a8c7c2049f6bf12dd814.tar.bz2
fork-ledger-fc8dd144673675d959a3a8c7c2049f6bf12dd814.zip
Create a py_value module, for translating value_t objects to/from Python.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3384170d..b5133c4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -194,13 +194,14 @@ if HAVE_BOOST_PYTHON
lib_LTLIBRARIES += libpyledger.la
libpyledger_la_SOURCES = \
+ python/pyutils.h \
+ python/pyfstream.h \
+ python/py_utils.cc \
+ python/py_times.cc \
python/py_amount.cc \
python/py_commodity.cc \
- python/py_times.cc \
- python/py_utils.cc \
- python/pyfstream.h \
+ python/py_value.cc \
python/pyinterp.cc \
- python/pyutils.h \
python/setup.py
libpyledger_la_CPPFLAGS = $(libledger_la_CPPFLAGS) -I$(srcdir)/python