summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 03:43:51 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:41 -0400
commit02c88132cfbd69a65f5f27c0c7efbf459a375283 (patch)
tree7dadfae7fce709a7faf4ca6fd85511fb9a3824ab /configure.in
parent0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2 (diff)
downloadfork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.tar.gz
fork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.tar.bz2
fork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.zip
Added --enable-boost-sd for linking about the static/debug variant of Boost.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in77
1 files changed, 46 insertions, 31 deletions
diff --git a/configure.in b/configure.in
index af5da038..cc9e7d8a 100644
--- a/configure.in
+++ b/configure.in
@@ -28,6 +28,42 @@ AM_PROG_LIBTOOL
# Checks for emacs lisp path
AM_PATH_LISPDIR
+# Check for options
+AC_ARG_ENABLE(debug,
+ [ --enable-debug Turn on debugging],
+ [case "${enableval}" in
+ yes) debug=true ;;
+ no) debug=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
+ esac],[debug=false])
+
+AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+
+AC_ARG_ENABLE(boost-sd,
+ [ --enable-boost-sd Use static/debug Boost libraries],
+ [case "${enableval}" in
+ yes) boost_sd=true ;;
+ no) boost_sd=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-boost-sd) ;;
+ esac],[boost_sd=false])
+
+if test x$boost_sd = xtrue; then
+ BOOST_SUFFIX="-sd"
+else
+ BOOST_SUFFIX=""
+fi
+AM_CONDITIONAL(USE_BOOST_SD, test x$boost_sd = xtrue)
+
+AC_ARG_ENABLE(pch,
+ [ --enable-pch Use GCC 4.x pre-compiled headers],
+ [case "${enableval}" in
+ yes) pch=true ;;
+ no) pch=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-pch) ;;
+ esac],[pch=false])
+
+AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
+
# check if UNIX pipes are available
AC_CACHE_CHECK(
[if pipes can be used],
@@ -72,7 +108,7 @@ AC_CACHE_CHECK(
[if boost_regex is available],
[boost_regex_avail],
[boost_regex_save_libs=$LIBS
- LIBS="-lboost_regex $LIBS"
+ LIBS="-lboost_regex$BOOST_SUFFIX $LIBS"
AC_LANG_PUSH(C++)
AC_TRY_LINK(
[#include <boost/regex.hpp>],
@@ -83,7 +119,7 @@ AC_CACHE_CHECK(
LIBS=$boost_regex_save_libs])
if [test x$boost_regex_avail = xtrue ]; then
- LIBS="-lboost_regex $LIBS"
+ LIBS="-lboost_regex$BOOST_SUFFIX $LIBS"
else
AC_MSG_FAILURE("Could not find boost_regex library (set CPPFLAGS and LDFLAGS?)")
fi
@@ -93,7 +129,7 @@ AC_CACHE_CHECK(
[if boost_date_time is available],
[boost_date_time_cpplib_avail],
[boost_date_time_save_libs=$LIBS
- LIBS="-lboost_date_time $LIBS"
+ LIBS="-lboost_date_time$BOOST_SUFFIX $LIBS"
AC_LANG_PUSH(C++)
AC_TRY_LINK(
[#include <boost/date_time/posix_time/posix_time.hpp>
@@ -122,7 +158,7 @@ AC_CACHE_CHECK(
LIBS=$boost_date_time_save_libs])
if [test x$boost_date_time_cpplib_avail = xtrue ]; then
- LIBS="-lboost_date_time $LIBS"
+ LIBS="-lboost_date_time$BOOST_SUFFIX $LIBS"
else
AC_MSG_FAILURE("Could not find boost_date_time library (set CPPFLAGS and LDFLAGS?)")
fi
@@ -132,7 +168,7 @@ AC_CACHE_CHECK(
[if boost_filesystem is available],
[boost_filesystem_cpplib_avail],
[boost_filesystem_save_libs=$LIBS
- LIBS="-lboost_filesystem $LIBS"
+ LIBS="-lboost_filesystem$BOOST_SUFFIX $LIBS"
AC_LANG_PUSH(C++)
AC_TRY_LINK(
[#include <boost/filesystem/path.hpp>],
@@ -143,7 +179,7 @@ AC_CACHE_CHECK(
LIBS=$boost_filesystem_save_libs])
if [test x$boost_filesystem_cpplib_avail = xtrue ]; then
- LIBS="-lboost_filesystem $LIBS"
+ LIBS="-lboost_filesystem$BOOST_SUFFIX $LIBS"
else
AC_MSG_FAILURE("Could not find boost_filesystem library (set CPPFLAGS and LDFLAGS?)")
fi
@@ -153,7 +189,7 @@ fi
# [if boost_signals is available],
# [boost_signals_cpplib_avail],
# [boost_signals_save_libs=$LIBS
-# LIBS="-lboost_signals $LIBS"
+# LIBS="-lboost_signals$BOOST_SUFFIX $LIBS"
# AC_LANG_PUSH(C++)
# AC_TRY_LINK(
# [#include <boost/signal.hpp>],
@@ -164,7 +200,7 @@ fi
# LIBS=$boost_signals_save_libs])
#
#if [test x$boost_signals_cpplib_avail = xtrue ]; then
-# LIBS="-lboost_signals $LIBS"
+# LIBS="-lboost_signals$BOOST_SUFFIX $LIBS"
#else
# AC_MSG_FAILURE("Could not find boost_signals library (set CPPFLAGS and LDFLAGS?)")
#fi
@@ -319,7 +355,7 @@ if [test x$python = xtrue ]; then
[if boost_python is available],
[boost_python_cpplib_avail],
[boost_python_save_libs=$LIBS
- LIBS="-lboost_python -lpython$PYTHON_VERSION $LIBS"
+ LIBS="-lboost_python$BOOST_SUFFIX -lpython$PYTHON_VERSION $LIBS"
AC_LANG_PUSH(C++)
AC_TRY_LINK(
[#include <boost/python.hpp>
@@ -336,7 +372,7 @@ if [test x$python = xtrue ]; then
if [test x$boost_python_cpplib_avail = xtrue ]; then
AM_CONDITIONAL(HAVE_BOOST_PYTHON, true)
- LIBS="-lboost_python -lpython$PYTHON_VERSION $LIBS"
+ LIBS="-lboost_python$BOOST_SUFFIX -lpython$PYTHON_VERSION $LIBS"
else
AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
fi
@@ -376,27 +412,6 @@ else
AM_CONDITIONAL(HAVE_CPPUNIT, false)
fi
-# Check for options
-AC_ARG_ENABLE(debug,
- [ --enable-debug Turn on debugging],
- [case "${enableval}" in
- yes) debug=true ;;
- no) debug=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
- esac],[debug=false])
-
-AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
-
-AC_ARG_ENABLE(pch,
- [ --enable-pch Use GCC 4.x pre-compiled headers],
- [case "${enableval}" in
- yes) pch=true ;;
- no) pch=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-pch) ;;
- esac],[pch=false])
-
-AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
-
# Checks for header files.
AC_STDC_HEADERS
AC_HAVE_HEADERS(sys/stat.h langinfo.h)