summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-04-19 20:31:46 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:28 -0400
commit0a6b5726ec3bf402a953ea8a03b98ecbf4b90b0c (patch)
tree0a2c2aca7100d045f491b03f0a5bda92378d3ef9 /configure.in
parent176b3044e355398a0c31e0c42a3cd7b8a2e3f3e5 (diff)
downloadfork-ledger-0a6b5726ec3bf402a953ea8a03b98ecbf4b90b0c.tar.gz
fork-ledger-0a6b5726ec3bf402a953ea8a03b98ecbf4b90b0c.tar.bz2
fork-ledger-0a6b5726ec3bf402a953ea8a03b98ecbf4b90b0c.zip
Made the amount/balance/value interface a bit more rational; added
back a useless version of the register command (just to prove the command sequence); and added smart XML semantics to the XPath implementation so that nodes can be coerced to values.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in78
1 files changed, 39 insertions, 39 deletions
diff --git a/configure.in b/configure.in
index d1f953e2..8bb6247f 100644
--- a/configure.in
+++ b/configure.in
@@ -68,51 +68,28 @@ if [test x$pipes_avail = xtrue ]; then
AC_DEFINE([HAVE_UNIX_PIPES], [1], [Whether UNIX pipes are available])
fi
-# check for gmp
-AC_CACHE_CHECK(
- [if libgmp is available],
- [libgmp_avail],
- [libgmp_save_libs=$LIBS
- LIBS="-lgmp $LIBS"
- AC_LANG_PUSH(C++)
- AC_TRY_LINK(
- [#include <gmp.h>],
- [mpz_t bar;
- mpz_init(bar);
- mpz_clear(bar);],
- [libgmp_avail=true],
- [libgmp_avail=false])
- AC_LANG_POP
- LIBS=$libgmp_save_libs])
-
-if [test x$libgmp_avail = xtrue ]; then
- LIBS="-lgmp $LIBS"
-else
- AC_MSG_FAILURE("Could not find gmp library (set CPPFLAGS and LDFLAGS?)")
-fi
-
-# check for pcre
+# check for boost_regex
AC_CACHE_CHECK(
- [if libpcre is available],
- [libpcre_avail],
- [libpcre_save_libs=$LIBS
- LIBS="-lpcre $LIBS"
+ [if boost_regex is available],
+ [boost_regex_avail],
+ [boost_regex_save_libs=$LIBS
+ LIBS="-lboost_regex $LIBS"
AC_LANG_PUSH(C++)
AC_TRY_LINK(
- [#include <pcre.h>],
- [pcre_free((pcre *)NULL);],
- [libpcre_avail=true],
- [libpcre_avail=false])
+ [#include <boost/regex.hpp>],
+ [boost::regex foo_regexp("Hello, world!");],
+ [boost_regex_avail=true],
+ [boost_regex_avail=false])
AC_LANG_POP
- LIBS=$libpcre_save_libs])
+ LIBS=$boost_regex_save_libs])
-if [test x$libpcre_avail = xtrue ]; then
- LIBS="-lpcre $LIBS"
+if [test x$boost_regex_avail = xtrue ]; then
+ LIBS="-lboost_regex $LIBS"
else
- AC_MSG_FAILURE("Could not find pcre library (set CPPFLAGS and LDFLAGS?)")
+ AC_MSG_FAILURE("Could not find boost_regex library (set CPPFLAGS and LDFLAGS?)")
fi
-# check for Boost date_time
+# check for boost_date_time
AC_CACHE_CHECK(
[if boost_date_time is available],
[boost_date_time_cpplib_avail],
@@ -151,6 +128,29 @@ else
AC_MSG_FAILURE("Could not find boost_date_time library (set CPPFLAGS and LDFLAGS?)")
fi
+# check for gmp
+AC_CACHE_CHECK(
+ [if libgmp is available],
+ [libgmp_avail],
+ [libgmp_save_libs=$LIBS
+ LIBS="-lgmp $LIBS"
+ AC_LANG_PUSH(C++)
+ AC_TRY_LINK(
+ [#include <gmp.h>],
+ [mpz_t bar;
+ mpz_init(bar);
+ mpz_clear(bar);],
+ [libgmp_avail=true],
+ [libgmp_avail=false])
+ AC_LANG_POP
+ LIBS=$libgmp_save_libs])
+
+if [test x$libgmp_avail = xtrue ]; then
+ LIBS="-lgmp $LIBS"
+else
+ AC_MSG_FAILURE("Could not find gmp library (set CPPFLAGS and LDFLAGS?)")
+fi
+
# check for expat or xmlparse
AC_ARG_ENABLE(xml,
[ --enable-xml Turn on support for XML parsing],
@@ -319,7 +319,7 @@ AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
# Checks for header files.
AC_STDC_HEADERS
-AC_HAVE_HEADERS(sys/stat.h)
+AC_HAVE_HEADERS(sys/stat.h langinfo.h)
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -329,7 +329,7 @@ AC_STRUCT_TM
# Checks for library functions.
#AC_FUNC_ERROR_AT_LINE
AC_HEADER_STDC
-AC_CHECK_FUNCS([access mktime realpath getpwuid getpwnam])
+AC_CHECK_FUNCS([access mktime realpath getpwuid getpwnam nl_langinfo])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT