summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2006-02-28 14:40:49 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 02:41:28 -0400
commit0c55a5ee1b5b35f399de7286cd8c6565a61e9634 (patch)
tree47c247481db46d478133eddade540f90c34402b3 /configure.in
parent9db08c4c7de7b2058363bec4a3000f48fc78d580 (diff)
downloadfork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.tar.gz
fork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.tar.bz2
fork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.zip
(read_binary_journal): Fixed a tiny memory leak when reading from a
binary cache.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in72
1 files changed, 67 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 88acb260..f595d3b7 100644
--- a/configure.in
+++ b/configure.in
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT(ledger, 2.5, johnw@newartisans.com)
-AM_INIT_AUTOMAKE(ledger, 2.5)
+AC_INIT(ledger, 2.6, johnw@newartisans.com)
+AM_INIT_AUTOMAKE(ledger, 2.6)
AC_CONFIG_SRCDIR([main.cc])
AC_CONFIG_HEADER([acconf.h])
@@ -129,7 +129,13 @@ if [test x$xml = xtrue ]; then
[libexpat_avail=false])
AC_LANG_POP
LIBS=$libexpat_save_libs])
- AM_CONDITIONAL(HAVE_EXPAT, test x$libexpat_avail = xtrue)
+
+ if [test x$libexpat_avail = xtrue ]; then
+ AM_CONDITIONAL(HAVE_EXPAT, true)
+ LIBS="-lexpat $LIBS"
+ else
+ AM_CONDITIONAL(HAVE_EXPAT, false)
+ fi
else
AM_CONDITIONAL(HAVE_EXPAT, false)
fi
@@ -153,7 +159,13 @@ if [test x$xml = xtrue ]; then
[libxmlparse_avail=false])
AC_LANG_POP
LIBS=$libxmlparse_save_libs])
- AM_CONDITIONAL(HAVE_XMLPARSE, test x$libxmlparse_avail = xtrue)
+
+ if [test x$libxmlparse_avail = xtrue ]; then
+ AM_CONDITIONAL(HAVE_XMLPARSE, true)
+ LIBS="-lxmlparse -lxmltok $LIBS"
+ else
+ AM_CONDITIONAL(HAVE_XMLPARSE, false)
+ fi
else
AM_CONDITIONAL(HAVE_XMLPARSE, false)
fi
@@ -185,11 +197,61 @@ if [test x$ofx = xtrue ]; then
[libofx_avail=false])
AC_LANG_POP
LIBS=$libofx_save_libs])
- AM_CONDITIONAL(HAVE_LIBOFX, test x$libofx_avail = xtrue)
+
+ if [test x$libofx_avail = xtrue ]; then
+ AM_CONDITIONAL(HAVE_LIBOFX, true)
+ LIBS="-lofx $LIBS"
+ else
+ AM_CONDITIONAL(HAVE_LIBOFX, false)
+ fi
else
AM_CONDITIONAL(HAVE_LIBOFX, false)
fi
+# check for Python
+AC_ARG_ENABLE(python,
+ [ --enable-python Build the amounts library as a Python module],
+ [case "${enableval}" in
+ yes) python=true ;;
+ no) python=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-python) ;;
+ esac],[python=false])
+AM_CONDITIONAL(USE_PYTHON, test x$python = xtrue)
+
+if [test x$python = xtrue ]; then
+ AM_PATH_PYTHON(2.2,, :)
+ if [test "$PYTHON" != :]; then
+ AC_CACHE_CHECK(
+ [if boost_python is available],
+ [boost_python_cpplib_avail],
+ [boost_python_save_libs=$LIBS
+ LIBS="-lboost_python -lpython$PYTHON_VERSION $LIBS"
+ AC_LANG_PUSH(C++)
+ AC_TRY_LINK(
+ [#include <boost/python.hpp>
+ using namespace boost::python;
+ class foo {};
+ BOOST_PYTHON_MODULE(samp) {
+ class_< foo > ("foo") ;
+ }],
+ [return 0],
+ [boost_python_cpplib_avail=true],
+ [boost_python_cpplib_avail=false])
+ AC_LANG_POP
+ LIBS=$boost_python_save_libs])
+ if [test x$boost_python_cpplib_avail = xtrue ]; then
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, true)
+ LIBS="-lboost_python -lpython$PYTHON_VERSION $LIBS"
+ else
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
+ fi
+ else
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
+ fi
+else
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
+fi
+
# Check for options
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on debugging],