summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2005-02-09 09:47:18 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 02:40:55 -0400
commit193a801c03f27d5888d6e7347c18fbc925b72f1d (patch)
treee509fdc72bcfb4d8f72290a2081a0568d7924fbc /configure.in
parentbbffd8632e2f70fd76533d02f338d1f3b618ca63 (diff)
downloadfork-ledger-193a801c03f27d5888d6e7347c18fbc925b72f1d.tar.gz
fork-ledger-193a801c03f27d5888d6e7347c18fbc925b72f1d.tar.bz2
fork-ledger-193a801c03f27d5888d6e7347c18fbc925b72f1d.zip
Added preliminary support for OFX, using libofx. Needs much
real-world testing.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7b00d506..3ea18391 100644
--- a/configure.in
+++ b/configure.in
@@ -111,6 +111,35 @@ else
AM_CONDITIONAL(HAVE_XMLPARSE, false)
fi
+# check for libofx
+AC_ARG_ENABLE(ofx,
+ [ --enable-ofx Turn on support for OFX/OCF parsing],
+ [case "${enableval}" in
+ yes) ofx=true ;;
+ no) ofx=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-ofx) ;;
+ esac],[ofx=true])
+AM_CONDITIONAL(USE_OFX, test x$ofx = xtrue)
+
+if [test x$ofx = xtrue ]; then
+ AC_CACHE_CHECK(
+ [if libofx is available],
+ [libofx_avail],
+ [libofx_save_libs=$LIBS
+ LIBS="-lofx $LIBS"
+ AC_LANG_PUSH(C++)
+ AC_TRY_LINK(
+ [#include <libofx.h>],
+ [ LibofxContextPtr libofx_context = libofx_get_new_context();],
+ [libofx_avail=true],
+ [libofx_avail=false])
+ AC_LANG_POP
+ LIBS=$libofx_save_libs])
+ AM_CONDITIONAL(HAVE_LIBOFX, test x$libofx_avail = xtrue)
+else
+ AM_CONDITIONAL(HAVE_LIBOFX, false)
+fi
+
# check for Python
AC_ARG_ENABLE(python,
[ --enable-python Turn on Python support],