summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2004-08-03 04:34:50 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 02:40:47 -0400
commita32173ace60df5a1e9414f5e95b556c436f62718 (patch)
treefff5b881c657fddb8543b0f787bfa75cf009a0b7 /configure.in
parentcc98b59d1e99238270eb307b117da8b0b35e6f27 (diff)
downloadfork-ledger-a32173ace60df5a1e9414f5e95b556c436f62718.tar.gz
fork-ledger-a32173ace60df5a1e9414f5e95b556c436f62718.tar.bz2
fork-ledger-a32173ace60df5a1e9414f5e95b556c436f62718.zip
changes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in98
1 files changed, 0 insertions, 98 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 7788528a..00000000
--- a/configure.in
+++ /dev/null
@@ -1,98 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.59)
-AC_INIT(ledger, 2.0b, johnw@netartisans.com)
-AM_INIT_AUTOMAKE(ledger, 2.0b)
-AC_CONFIG_SRCDIR([main.cc])
-AC_CONFIG_HEADER([acconf.h])
-
-# Checks for programs.
-AC_PROG_CXX
-AC_PROG_MAKE_SET
-AC_PROG_LIBTOOL
-AM_PROG_LIBTOOL
-#AC_PROG_RANLIB
-
-# Checks for libraries.
-AC_CHECK_LIB([gmp], [__gmpz_add], [],
- AC_MSG_FAILURE("Could not find gmp (GNU multi-precision) library"))
-AC_CHECK_LIB([pcre], [pcre_compile], [],
- AC_MSG_FAILURE("Could not find pcre (Perl regular expression) library"))
-AC_CHECK_LIB([xmlparse], [XML_ParserCreate],
- [AC_DEFINE([READ_GNUCASH], [1], [Support reading gnucash files])
- AM_CONDITIONAL(READ_GNUCASH, true)
- AC_SUBST(LIBS, "-lxmlparse -lxmltok $LIBS")],
- [AC_MSG_NOTICE([Could not find xmlparse library: Gnucash support disabled])
- AM_CONDITIONAL(READ_GNUCASH, false)],
- [-lxmltok])
-
-AC_ARG_ENABLE(python,
- [ --enable-python Turn on Python support],
- [case "${enableval}" in
- yes) python=true ;;
- no) python=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-python) ;;
- esac],[python=false])
-AM_CONDITIONAL(USE_PYTHON, test x$python = xtrue)
-
-if [test x$python = xtrue ]; then
- AM_PATH_PYTHON(2.2,, :)
- if [test "$PYTHON" != :]; then
- AC_CACHE_CHECK(
- [if boost_python is available],
- [boost_python_cpplib_avail],
- [boost_python_save_libs=$LIBS
- LIBS="-lboost_python $LIBS"
- AC_LANG_PUSH(C++)
- AC_TRY_COMPILE(
- [#include <boost/python.hpp>
- using namespace boost::python;
- class foo {};
- BOOST_PYTHON_MODULE(samp) {
- class_< foo > ("foo") ;
- }],
- [return 0],
- [boost_python_cpplib_avail=true],
- [boost_python_cpplib_avail=false])
- AC_LANG_POP
- LIBS=$boost_python_save_libs])
- AM_CONDITIONAL(HAVE_BOOST_PYTHON,
- test x$boost_python_cpplib_avail = xtrue)
- else
- AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
- fi
-else
- AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
-fi
-
-# Check for options
-AC_ARG_ENABLE(debug,
- [ --enable-debug Turn on debugging],
- [case "${enableval}" in
- yes) debug=true ;;
- no) debug=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
- esac],[debug=false])
-AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
-
-# Checks for header files.
-AC_STDC_HEADERS
-AC_HAVE_HEADERS(sys/stat.h)
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_TYPE_SIZE_T
-AC_STRUCT_TM
-
-# Checks for library functions.
-#AC_FUNC_ERROR_AT_LINE
-AC_HEADER_STDC
-#AC_FUNC_MALLOC
-#AC_FUNC_MKTIME
-#AC_FUNC_STAT
-#AC_FUNC_STRFTIME
-AC_CHECK_FUNCS([memset strchr strstr access mktime stat strftime])
-
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT