summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 03:55:00 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:41 -0400
commitd594f6627c947f965b6e43a1291f37e495c22261 (patch)
treef1d861ef86cdb87c101b6a9f1bb36622783d5528 /configure.in
parentbfa77b9e8db6d5c1c96360a5b536b82d3add574c (diff)
downloadfork-ledger-d594f6627c947f965b6e43a1291f37e495c22261.tar.gz
fork-ledger-d594f6627c947f965b6e43a1291f37e495c22261.tar.bz2
fork-ledger-d594f6627c947f965b6e43a1291f37e495c22261.zip
Added --enable-boost-d flag.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cc9e7d8a..2a024690 100644
--- a/configure.in
+++ b/configure.in
@@ -47,12 +47,25 @@ AC_ARG_ENABLE(boost-sd,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-boost-sd) ;;
esac],[boost_sd=false])
+AM_CONDITIONAL(USE_BOOST_SD, test x$boost_sd = xtrue)
+
+AC_ARG_ENABLE(boost-d,
+ [ --enable-boost-d Use dynamic/debug Boost libraries],
+ [case "${enableval}" in
+ yes) boost_d=true ;;
+ no) boost_d=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-boost-d) ;;
+ esac],[boost_d=false])
+
+AM_CONDITIONAL(USE_BOOST_D, test x$boost_d = xtrue)
+
if test x$boost_sd = xtrue; then
BOOST_SUFFIX="-sd"
+elif test x$boost_d = xtrue; then
+ BOOST_SUFFIX="-d"
else
BOOST_SUFFIX=""
fi
-AM_CONDITIONAL(USE_BOOST_SD, test x$boost_sd = xtrue)
AC_ARG_ENABLE(pch,
[ --enable-pch Use GCC 4.x pre-compiled headers],