summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorCraig Earls <enderw88@gmail.com>2014-04-19 21:56:14 -0700
committerCraig Earls <enderw88@gmail.com>2014-04-19 21:56:14 -0700
commitfd18f58392833d6e1b1c06a7700f8afc37711c87 (patch)
tree895daa013b63caeed47bd944daba89003e9b34ce /default.nix
parent7faaeb301fe524422c694e54fa36248ffedfa9b8 (diff)
parenta0c5addbbdaf472d26ae25c86ff826e509b3ee17 (diff)
downloadfork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.tar.gz
fork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.tar.bz2
fork-ledger-fd18f58392833d6e1b1c06a7700f8afc37711c87.zip
Merge commit 'a0c5addbbdaf472d26ae25c86ff826e509b3ee17'
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..f1745ce4
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchgit, cmake, boost, gmp, mpfr, libedit, python
+, texinfo, gnused }:
+
+let
+ rev = "20140417";
+in
+
+stdenv.mkDerivation {
+ name = "ledger-3.0.2.${rev}";
+
+ src = ./.;
+
+ buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];
+
+ enableParallelBuilding = true;
+
+ # Skip byte-compiling of emacs-lisp files because this is currently
+ # broken in ledger...
+ postInstall = ''
+ mkdir -p $out/share/emacs/site-lisp/
+ cp -v $src/lisp/*.el $out/share/emacs/site-lisp/
+ '';
+
+ meta = {
+ homepage = "http://ledger-cli.org/";
+ description = "A double-entry accounting system with a command-line reporting interface";
+ license = "BSD";
+
+ longDescription = ''
+ Ledger is a powerful, double-entry accounting system that is accessed
+ from the UNIX command-line. This may put off some users, as there is
+ no flashy UI, but for those who want unparalleled reporting access to
+ their data, there really is no alternative.
+ '';
+
+ platforms = stdenv.lib.platforms.all;
+ maintainers = with stdenv.lib.maintainers; [ simons the-kenny jwiegley ];
+ };
+}