summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2023-04-09 21:48:04 +0200
committerAlexis Hildebrandt <afh@surryhill.net>2023-04-10 11:04:27 +0200
commit2bfe283b68dabfa6cfcbc3e46ab619a222354a6a (patch)
tree4e1f62fdc1198431228f9431552af0d7c3c96a2b /doc/CMakeLists.txt
parent75c1aeb269285a41c388e416ed1cb5f1108ddb44 (diff)
downloadfork-ledger-2bfe283b68dabfa6cfcbc3e46ab619a222354a6a.tar.gz
fork-ledger-2bfe283b68dabfa6cfcbc3e46ab619a222354a6a.tar.bz2
fork-ledger-2bfe283b68dabfa6cfcbc3e46ab619a222354a6a.zip
doc: Add support for extra css to api documentation
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 1459bac7..9f5745ea 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -9,6 +9,9 @@ cmake_minimum_required(VERSION 3.16.2)
project(ledger NONE)
+set(DOXYGEN_EXTRA_CSS CACHE STRING
+ "Path to extra css file added to the generated API documentation")
+
# Point CMake at any custom modules we may ship
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}")
include(LedgerVersion)
@@ -28,11 +31,13 @@ if (USE_DOXYGEN)
# see INPUT/FILE_PATTERNS in Doxyfile.in
file(GLOB doxygen_input_files ${CMAKE_CURRENT_SOURCE_DIR}/../src/*.h)
- add_custom_command(OUTPUT html/index.html
+ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/html/index.html
COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile ${doxygen_input_files}
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "Building doxygen documentation")
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html
+ DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT doc)
add_custom_target(doc.doxygen DEPENDS html/index.html)
else()
add_custom_target(doc.doxygen)