summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2014-05-04 01:14:39 +0200
committerAlexis Hildebrandt <afh@surryhill.net>2014-05-04 01:14:39 +0200
commit87bcfee8fd3054fa22deb1cc2e8eb32943c509e3 (patch)
tree5a917b5e455b7206b4b8b026fd83f43e74bbba11 /doc/CMakeLists.txt
parentcdfd7e58503e6f71212b734b7c85f1ed8ccaf3b7 (diff)
downloadfork-ledger-87bcfee8fd3054fa22deb1cc2e8eb32943c509e3.tar.gz
fork-ledger-87bcfee8fd3054fa22deb1cc2e8eb32943c509e3.tar.bz2
fork-ledger-87bcfee8fd3054fa22deb1cc2e8eb32943c509e3.zip
Build info version of documentation
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 15f1318c..cd68f828 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -43,6 +43,17 @@ find_program(GROFF groff)
foreach(file ${info_files})
get_filename_component(file_base ${file} NAME_WE)
+
+ if(NOT MAKEINFO)
+ message(WARNING "Could not find makeinfo. Info version of documentation cannot be built.")
+ else()
+ add_custom_command(OUTPUT ${file_base}.info
+ COMMAND makeinfo --force --no-split -o ${file_base}.info ${CMAKE_CURRENT_SOURCE_DIR}/${file}
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${file}
+ VERBATIM)
+ list(APPEND ledger_doc_files ${file_base}.info)
+ endif()
+
if(BUILD_WEB_DOCS)
if(NOT MAKEINFO)
message(FATAL_ERROR "Could not find makeinfo. HTML version of documentation cannot be built.")