summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Earls <enderw88@gmail.com>2014-05-18 08:25:30 -0700
committerCraig Earls <enderw88@gmail.com>2014-05-18 08:25:30 -0700
commit8e6cdcc1d13533252b1f6e6088dca966b64e4c88 (patch)
tree8f8fd4f644f292a25fb79d59961e135cc4b11c3a /doc/CMakeLists.txt
parentd82c1b4b5531c7be1c1870a07f1836b230a4da27 (diff)
parent4af2b97921a68a522135f958f1999ec4b63435bb (diff)
downloadfork-ledger-8e6cdcc1d13533252b1f6e6088dca966b64e4c88.tar.gz
fork-ledger-8e6cdcc1d13533252b1f6e6088dca966b64e4c88.tar.bz2
fork-ledger-8e6cdcc1d13533252b1f6e6088dca966b64e4c88.zip
Merge branch 'master' of https://github.com/ledger/ledger
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 798ec422..9bf1bffe 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -7,7 +7,7 @@
if (USE_DOXYGEN)
find_package(Doxygen)
- if(NOT DOXYGEN_FOUND)
+ if (NOT DOXYGEN_FOUND)
message(FATAL_ERROR "Could not find doxygen. Reference documentation cannot be built.")
endif()
@@ -27,7 +27,7 @@ endif()
########################################################################
-if(NOT BUILD_DOCS)
+if (NOT BUILD_DOCS)
add_custom_target(doc DEPENDS doc.doxygen)
return()
endif()
@@ -45,7 +45,7 @@ find_program(GROFF groff)
foreach(file ${info_files})
get_filename_component(file_base ${file} NAME_WE)
- if(NOT MAKEINFO)
+ if (NOT MAKEINFO)
message(WARNING "Could not find makeinfo. Info version of documentation cannot be built.")
else()
add_custom_command(OUTPUT ${file_base}.info
@@ -55,8 +55,8 @@ foreach(file ${info_files})
list(APPEND ledger_doc_files ${file_base}.info)
endif()
- if(BUILD_WEB_DOCS)
- if(NOT MAKEINFO)
+ if (BUILD_WEB_DOCS)
+ if (NOT MAKEINFO)
message(WARNING "Could not find makeinfo. HTML version of documentation cannot be built.")
endif()
add_custom_command(OUTPUT ${file_base}.html
@@ -66,10 +66,10 @@ foreach(file ${info_files})
list(APPEND ledger_doc_files ${file_base}.html)
endif(BUILD_WEB_DOCS)
- if(NOT TEXI2PDF OR NOT TEX)
+ if (NOT TEXI2PDF OR NOT TEX)
message(WARNING "Could not find texi2pdf or tex. PDF version of documentation will not be built.")
else()
- if(BUILD_A4_PDF)
+ if (BUILD_A4_PDF)
set(papersize --texinfo=@afourpaper)
endif()
add_custom_command(OUTPUT ${file_base}.pdf
@@ -82,12 +82,12 @@ endforeach()
########################################################################
-if(BUILD_WEB_DOCS)
+if (BUILD_WEB_DOCS)
include(FindUnixCommands)
- if(NOT BASH)
+ if (NOT BASH)
message(FATAL_ERROR "Could not find bash. Unable to build documentation.")
endif()
- if(MAN2HTML)
+ if (MAN2HTML)
add_custom_command(OUTPUT ledger.1.html
COMMAND ${BASH} -c "man2html ${CMAKE_CURRENT_SOURCE_DIR}/ledger.1 | tail -n+3 > ledger.1.html"
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/ledger.1
@@ -112,7 +112,7 @@ add_custom_target(doc DEPENDS ${ledger_doc_files} doc.doxygen)
include(GNUInstallDirs)
-if(CMAKE_INSTALL_MANDIR)
+if (CMAKE_INSTALL_MANDIR)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/ledger.1
DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT doc)
endif(CMAKE_INSTALL_MANDIR)