summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2023-06-10 17:17:42 +0200
committerGitHub <noreply@github.com>2023-06-10 17:17:42 +0200
commitb59356351e240f7286febb599f6dfd1e6f6e4cb4 (patch)
tree950a92dbecdaed1284cf111da4f9810c09c5aa98 /flake.nix
parent82f72f4f836251846492948aebd54a7536bc6da7 (diff)
parent1d422c32d6c3b137e8cb4a95b68fbd035107a7e5 (diff)
downloadfork-ledger-b59356351e240f7286febb599f6dfd1e6f6e4cb4.tar.gz
fork-ledger-b59356351e240f7286febb599f6dfd1e6f6e4cb4.tar.bz2
fork-ledger-b59356351e240f7286febb599f6dfd1e6f6e4cb4.zip
Merge pull request #2259 from afh/afh-readline
Improve support for libedit and readline
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index a992594b..de591136 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,6 +6,8 @@
outputs = { self, nixpkgs }: let
usePython = true;
gpgmeSupport = true;
+ useLibedit = true;
+ useReadline = false;
forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; });
systems = [ "x86_64-linux" "aarch64-linux" "x86_64-darwin" "aarch64-darwin" ];
@@ -23,14 +25,24 @@
outputs = [ "out" "dev" ] ++ lib.optionals usePython [ "py" ];
buildInputs = [
- gmp mpfr libedit gnused
+ gmp mpfr gnused
+ ] ++ lib.optionals useLibedit [
+ libedit
+ ] ++ lib.optionals useReadline [
+ readline
] ++ lib.optionals gpgmeSupport [
gpgme
] ++ (if usePython
then [ python3 (boost.override { enablePython = true; python = python3; }) ]
else [ boost ]);
- nativeBuildInputs = [ cmake texinfo tzdata ];
+ nativeBuildInputs = [
+ cmake texinfo tzdata
+ ] ++ lib.optionals useLibedit [
+ libedit.dev
+ ] ++ lib.optionals useReadline [
+ readline.dev
+ ];
enableParallelBuilding = true;