diff options
author | John Wiegley <johnw@newartisans.com> | 2007-04-15 11:45:07 +0000 |
---|---|---|
committer | John Wiegley <johnw@newartisans.com> | 2008-04-13 03:35:33 -0400 |
commit | 205351c9f9687f9f354d221145017298adf58fd5 (patch) | |
tree | 52dd3c0bf1b14f1cc7c734b8bc8f5b57e05c7eaf /setup.py | |
parent | fc6b8837ecdf1891fcd52e0ff60c2b9275acd28e (diff) | |
download | fork-ledger-205351c9f9687f9f354d221145017298adf58fd5.tar.gz fork-ledger-205351c9f9687f9f354d221145017298adf58fd5.tar.bz2 fork-ledger-205351c9f9687f9f354d221145017298adf58fd5.zip |
Added python tests.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 23 |
1 files changed, 6 insertions, 17 deletions
@@ -3,24 +3,13 @@ from distutils.core import setup, Extension import os +import string defines = [('PYTHON_MODULE', 1)] +if os.environ.has_key("DEBUG_LEVEL"): + defines.extend ([('DEBUG_LEVEL', os.environ["DEBUG_LEVEL"])]) -defines.extend ([('DEBUG_LEVEL', 4)]) - -libs = ["pyledger", "ledger", "boost_python", "gmp", "pcre"] - -if os.environ.has_key ("HAVE_EXPAT") and\ - os.environ["HAVE_EXPAT"] == "true": - libs.extend (["expat"]) - -if os.environ.has_key ("HAVE_XMLPARSE") and\ - os.environ["HAVE_XMLPARSE"] == "true": - libs.extend (["xmlparse", "xmltok"]) - -if os.environ.has_key ("HAVE_LIBOFX") and\ - os.environ["HAVE_LIBOFX"] == "true": - libs.extend (["ofx"]) +libs = os.environ["PYLIBS"].split() setup(name = "Ledger", version = "3.0", @@ -29,5 +18,5 @@ setup(name = "Ledger", author_email = "johnw@newartisans.com", url = "http://johnwiegley.com/", ext_modules = [ - Extension("ledger", ["pyledger.cc"], - define_macros = defines, libraries = libs)]) + Extension("ledger", ["pyledger.cc"], + define_macros = defines, libraries = libs)]) |