diff options
author | John Wiegley <johnw@newartisans.com> | 2004-09-14 20:32:42 -0400 |
---|---|---|
committer | John Wiegley <johnw@newartisans.com> | 2004-09-14 20:32:42 -0400 |
commit | 50a322adcfa3c1ac375e061270e73bc76c57cc47 (patch) | |
tree | a53a4e358507e16c933e9b428d9a0a00d6d4d840 /setup.py | |
parent | 5d99b1e24179d65e75431b8d5dfbe6e11acb0d24 (diff) | |
download | fork-ledger-50a322adcfa3c1ac375e061270e73bc76c57cc47.tar.gz fork-ledger-50a322adcfa3c1ac375e061270e73bc76c57cc47.tar.bz2 fork-ledger-50a322adcfa3c1ac375e061270e73bc76c57cc47.zip |
main.py (via ledger.so) and main.cc can now use the same shared library
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -2,6 +2,8 @@ from distutils.core import setup, Extension +libs = ["ledger", "boost_python", "gmp", "pcre", "xmlparse", "xmltok"] + #setup(name = "Amounts", # version = "2.0b", # description = "Amounts Library", @@ -10,8 +12,8 @@ from distutils.core import setup, Extension # url = "http://www.newartisans.com/johnw/", # ext_modules = [ # Extension("amounts", ["pyamounts.cc"], -# define_macros = [('PYTHON_MODULE', None)], -# libraries = ["ledger_bpy", "boost_python", "gmp"])]) +# define_macros = [('PYTHON_MODULE', 1)], +# libraries = libs)]) setup(name = "Ledger", version = "2.0b", @@ -21,6 +23,5 @@ setup(name = "Ledger", url = "http://www.newartisans.com/johnw/", ext_modules = [ Extension("ledger", ["pyledger.cc"], - define_macros = [('PYTHON_MODULE', None)], - libraries = ["ledger_bpy", "boost_python", "gmp", - "pcre", "xmlparse", "xmltok"])]) + define_macros = [('PYTHON_MODULE', 1)], + libraries = libs)]) |