summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2004-09-14 04:47:41 -0400
committerJohn Wiegley <johnw@newartisans.com>2004-09-14 04:47:41 -0400
commita013b520ba151b9da3adec97d124676a96741b04 (patch)
tree4ee4d75800f9b9dd08c95283212fbdb7c71c1aee /setup.py
parent6c66d1e0ef09f113bca11cfb5ef0f35eebcc61a3 (diff)
downloadfork-ledger-a013b520ba151b9da3adec97d124676a96741b04.tar.gz
fork-ledger-a013b520ba151b9da3adec97d124676a96741b04.tar.bz2
fork-ledger-a013b520ba151b9da3adec97d124676a96741b04.zip
python integrated both ways (see sample.dat), and initialized on-demand
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..5cb1e67e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+setup(name = "Amounts",
+ version = "2.0b",
+ description = "Amounts Library",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/johnw/",
+ ext_modules = [
+ Extension("amounts", ["pyamounts.cc"],
+ define_macros = [('PYTHON_MODULE', None)],
+ libraries = ["ledger_bpy", "boost_python", "gmp"])])
+
+setup(name = "Ledger",
+ version = "2.0b",
+ description = "Ledger Accounting Tool",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/johnw/",
+ ext_modules = [
+ Extension("ledger", ["pyledger.cc"],
+ define_macros = [('PYTHON_MODULE', None)],
+ libraries = ["ledger_bpy", "boost_python", "gmp",
+ "pcre", "xmlparse", "xmltok"])])