diff options
author | John Wiegley <johnw@newartisans.com> | 2008-04-12 01:40:49 -0400 |
---|---|---|
committer | John Wiegley <johnw@newartisans.com> | 2008-05-08 02:50:19 -0400 |
commit | b45037e334ca336498217d4f54756c319c074d7b (patch) | |
tree | d0f8338df6c8adf86debcdcf236a25bbdd8d305b /setup.py | |
parent | 289cc97d45bbd3a8cdfcc3371ade71715b75b000 (diff) | |
download | fork-ledger-b45037e334ca336498217d4f54756c319c074d7b.tar.gz fork-ledger-b45037e334ca336498217d4f54756c319c074d7b.tar.bz2 fork-ledger-b45037e334ca336498217d4f54756c319c074d7b.zip |
Migrated over both code and build environment from was-v3.0 branch.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 18 |
1 files changed, 10 insertions, 8 deletions
@@ -4,15 +4,17 @@ from distutils.core import setup, Extension import os -libs = ["amounts", "boost_python", "gmp"] +defines = [('PYTHON_MODULE', 1)] +libs = os.environ["PYLIBS"].split() -setup(name = "Amounts", - version = "2.6.0.90", - description = "Amounts and Commodities Library", +setup(name = "Ledger", + version = "2.7", + description = "Ledger Accounting Library", author = "John Wiegley", author_email = "johnw@newartisans.com", - url = "http://www.newartisans.com/johnw/", + url = "http://www.newartisans.com/software/ledger.html", ext_modules = [ - Extension("amounts", ["amounts.cc"], - define_macros = [('PYTHON_MODULE', 1)], - libraries = libs)]) + Extension("ledger", + [os.path.join(os.environ['SRCDIR'], + "src", "python", "pyledger.cc")], + define_macros = defines, libraries = libs)]) |