summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2006-02-15 20:10:49 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 02:41:21 -0400
commitce3491c99f089874725999ca6d8b1fb6a15c9e5e (patch)
treec48a2bf19a954c8103a02e26f9a1a490b8095268 /setup.py
parent2eafddc91b8d7f0b7bdfd991acdc9e0b2295e304 (diff)
downloadfork-ledger-ce3491c99f089874725999ca6d8b1fb6a15c9e5e.tar.gz
fork-ledger-ce3491c99f089874725999ca6d8b1fb6a15c9e5e.tar.bz2
fork-ledger-ce3491c99f089874725999ca6d8b1fb6a15c9e5e.zip
Removed Python integration support.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 0 insertions, 30 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 79ed0d5f..00000000
--- a/setup.py
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/usr/bin/env python
-
-from distutils.core import setup, Extension
-
-import os
-
-libs = ["ledger", "boost_python", "gmp", "pcre"]
-
-if os.environ.has_key ("HAVE_EXPAT") and\
- os.environ["HAVE_EXPAT"] == "true":
- libs.extend (["expat"])
-
-if os.environ.has_key ("HAVE_XMLPARSE") and\
- os.environ["HAVE_XMLPARSE"] == "true":
- libs.extend (["xmlparse", "xmltok"])
-
-if os.environ.has_key ("HAVE_LIBOFX") and\
- os.environ["HAVE_LIBOFX"] == "true":
- libs.extend (["ofx"])
-
-setup(name = "Ledger",
- version = "2.5",
- description = "Ledger Accounting Tool",
- author = "John Wiegley",
- author_email = "johnw@newartisans.com",
- url = "http://www.newartisans.com/ledger.html",
- ext_modules = [
- Extension("ledger", ["pyledger.cc"],
- define_macros = [('PYTHON_MODULE', 1)],
- libraries = libs)])